Page 1 of 1

SCOE 2008 Problem

Posted: Tue Feb 16, 2010 1:10 pm
by SenescoMarine
I am trying to run the ShipConstructor 2008 Object enabler on a workstation running AutoCAD 2009.

The installer seems to run just fine, reports no errors. But the drawings are still not showing any of the ShipConstructor part #'s or markups.

I have other machines running the same configuration and they are all displaying everything properly.

I have tried uninstalling and reinstalling several times to no avail.

AutoCAD seems to be complaining about a DLL file being missing. The following is the output that I am getting from the AutoCAD session in question.

Code: Select all

Customization file loaded successfully. Customization Group: IMPRESSION
Customization file loaded successfully. Customization Group: CONTENTSEARCH
Customization file loaded successfully. Customization Group: EXPRESS
C:\Program Files\AutoCAD 
2009\ShipConstructor2008_ARX09\SConSharedObjectsDBX2008.dbx cannot find a dll 
or other file that it needs.
C:\Program Files\AutoCAD 
2009\ShipConstructor2008_ARX09\SConStructureDBX2008.dbx cannot find a dll or 
other file that it needs.
C:\Program Files\AutoCAD 
2009\ShipConstructor2008_ARX09\SConSharedObjectsDBX2008.dbx cannot find a dll 
or other file that it needs.
Opening an AutoCAD 2007 format file.
Regenerating layout.
Regenerating model.
AutoCAD Express Tools Copyright © 2002-2004 Autodesk, Inc.
Command:
AutoCAD menu utilities loaded.
Autodesk DWG.  This file is a TrustedDWG last saved by an Autodesk application 
or Autodesk licensed application.
Command: _RIBBON
Command: COMMANDLINE
Command: properties
Command: EXTERNALREFERENCES
I have also made sure that "C:\Program Files\AutoCAD 2009\ShipConstructor2008_ARX09\" was added to the support files paths, thinking that maybe it just didn't know where to look for the files that it is missing.

Any help would be greatly appreciated.

Re: SCOE 2008 Problem

Posted: Thu Feb 18, 2010 8:43 am
by SenescoMarine
Still looking for some insight on this. We have an engineer that can't review work packages because of this issue.

-Rob Anthony
Senesco Marine

Re: SCOE 2008 Problem

Posted: Thu Feb 18, 2010 10:07 am
by SSI Justin Paquin
Do you have any other AutoCAD versions on the workstation in question? If you do, try the Object Enabler, uninstalling all versions of AutoCAD and just reinstall AutoCAD 2009 followed by the Object Enabler. If you already have just AutoCAD 2009, try uninstalling both the Object Enabler and AutoCAD 2009 and reinstalling.

Re: SCOE 2008 Problem

Posted: Thu Feb 18, 2010 1:23 pm
by SenescoMarine
All workstations have AutoCAD 2005 and AutoCAD 2009 installed. All machines also have the SC 2005 OE and SC 2008 OE as the engineering firm we work with is turning out ShipConstructor 2005 drawings for one set of projects, and ShipConstructor 2008 drawings for other projects.